Jump to content


Photo

Why caní»t I see Chinese characters in the Posting Preview


  • Please log in to reply
8 replies to this topic

#1 Bigguy_33

Bigguy_33

    Sophomore Member

  • Members
  • PipPipPip
  • 180 posts

Posted 15 January 2015 - 12:37 AM

Sir: What am I doing wrong? Why can’t I see Chinese characters that I use in a posting when I select “posting preview” from the posting editor window? I can’t even see Chinese characters in the preview window, if all I am doing is quoting another members posting with Chinese character in the quote.

Thanks,

 



#2 NUWORLD

NUWORLD

    ╬Ď░«Íđ╣˙

  • Members
  • 2,084 posts

Posted 15 January 2015 - 04:29 AM

Sir: What am I doing wrong? Why can’t I see Chinese characters that I use in a posting when I select “posting preview” from the posting editor window? I can’t even see Chinese characters in the preview window, if all I am doing is quoting another members posting with Chinese character in the quote.

Thanks,

 

 

 

You may need to install the Chinese Language pack on your computer.

 

Translation from above:

您可能需要在电脑上安装了中国语言包。

 

Can you see Chinese characters now?

If not, you will need the Chinese language pack on your computer.

 

There will be others posting soon with more help.


Edited by NUWORLD, 15 January 2015 - 04:30 AM.


#3 dnoblett

dnoblett

    Here to help

  • Admin
  • 19,081 posts

Posted 15 January 2015 - 07:46 AM

Running an obsolete version of windows such as Windows XP?

 

If so then you may need to add the character set.

 

This website uses Chinese characters on many pages. Your web browser must be properly configured to see them.

 

If the line below displays question marks, blank boxes, or other strange characters, you have to change the settings to view Chinese characters.

 

祝你能夠很愉快的學習中文

 

  1. Access the Control Panel by clicking on Start --> Settings --> Control Panel. In the Control Panel, double click on "Regional and Language Options."
     
  2. Click on the Languages tab. Click on the check box marked "Install files for East Asian languages" and click OK.
     
  3. Click OK in the "Install Supplemental Language" alert box, and then click on OK in the Regional and Language Options dialog box.
     
  4. You will be prompted to insert the Windows XP installation disk which has the language support files. Insert the Windows XP installation CD, or if you have the language support files in another location, browse to the files and click OK. The language support files will be installed on your computer and you will be prompted to restart the computer.

    Click Yes to restart the computer.

    After your computer has restarted, be sure to check back to this page of this tutorial to see if the Chinese characters are displaying correctly.

http://mandarin.abou...tm#step-heading

Or from Microsoft: https://www.microsof...s.mspx?mfr=true



#4 dnoblett

dnoblett

    Here to help

  • Admin
  • 19,081 posts

Posted 15 January 2015 - 09:01 AM

If you don't have the windows install disk, you can download the character sets here.

Simplified Chinese: http://www.microsoft...s.aspx?id=14577

Traditional Chinese: http://www.microsoft...s.aspx?id=12072

Japanese: http://www.microsoft...s.aspx?id=10550

Korean: http://www.microsoft...s.aspx?id=10490

 

https://en.wikipedia...rt_(East_Asian)



#5 dnoblett

dnoblett

    Here to help

  • Admin
  • 19,081 posts

Posted 15 January 2015 - 09:19 AM

I see what you mean by problem with preview, I will have to look into this, the post editor has always been a problem on the board, I rarely use the post preview function.

 

BrokenPreview2_zps54d7049a.jpg

 

BrokenPreview_zps7961b328.jpg

 

I will have to look into this.



#6 Bigguy_33

Bigguy_33

    Sophomore Member

  • Members
  • PipPipPip
  • 180 posts

Posted 15 January 2015 - 10:39 AM

Thank you so much for helping me.

 

I’ve been on this site for 10+ years and for the last 4 years I’ve been studying Chinese almost everyday. I haven’t had a problem writing, reading or posting Chinese characters before on any site.  It was just the editor’s "preview post" window, which I use each time before I post which concerned me. I didn’t want to make a post with missing characters.

 

I am using Windows 7 Professional, with Servie Pack 1.

 

As a test, below are some Chinese characters, if I see them on my posting, then all is good.

 

/span>  (no Chinese characters appeared)

 

Hmmmm. looks like it me.....

 

Test #2  我的生活乱七八糟. -   this was copied from Google translation page, but editing my original post

Test #3 这是好雨知时节.  - this is being copied from MS Word 2002 - but editing my original post


Edited by Bigguy_33, 15 January 2015 - 10:49 AM.


#7 dnoblett

dnoblett

    Here to help

  • Admin
  • 19,081 posts

Posted 15 January 2015 - 10:56 AM

There is a bug somewhere in the code, for the most part the editing box shows you what the post will look like. There is a switch in the upper left of the editor that toggles between a basic code editor and the more word like editor, toggling back and forth will result in getting the view within the editor to give you a "preview" of your post.

 

The post editor has always had issues the worse were when we upgraded the software a couple years back, with each upgrade problems seem to be corrected, however it looks like you stumbled on something that has not been fixed by Invision Power Board.



#8 Bigguy_33

Bigguy_33

    Sophomore Member

  • Members
  • PipPipPip
  • 180 posts

Posted 15 January 2015 - 10:58 AM

Test #4  好雨時節  copied from MS Word using AR PL New Sung fonts - directly into the editor window

 

 

 

Test #5  copied from MS Word - but changing fonts with CFL editor window 

 

Thank you for the nice reply. I hope you enjoyed 好雨時節 .  I’ve learned a few wonderful Mandarin expressions from the movie. As you can guess the first one I learned is 这是好雨知时节”. I can’t wait until someday, I’m able to use that expression. Additionally, I read DuFu’s poem “Welcome Rain on a Spring Night” from which that line in the movie is taken. I also enjoyed the traditional Chinese song 凤凰 姑娘 (Phoenix Girls), which is in the movie.


Edited by Bigguy_33, 15 January 2015 - 11:03 AM.


#9 Bigguy_33

Bigguy_33

    Sophomore Member

  • Members
  • PipPipPip
  • 180 posts

Posted 15 January 2015 - 11:07 AM

Thank you Mr. dnoblett  it looks like I am on my way.....




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users